Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 cannot check for updates & error 0x80070002

20 Oct 2012   #11

Windows 7 Home Premium x64

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->
Validation Code: 0
Cached Online Validation Code: N/A, hr = 0xc004f012
Windows Product Key: *****-*****-2QWT6-HCQXJ-9YQTR
Windows Product Key Hash: PVjSC5x6njvqunmbCY3lOD7rYDo=
Windows Product ID: 00359-OEM-8992687-00007
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7600.2.00010300.0.0.003
ID: {40BE6A72-F9D1-4FD8-B8CA-196745FEF70B}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7600.win7_rtm.090713-1255
TTS Error:
Validation Diagnostic:
Resolution Status: N/A
Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002
OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002
OGA Data-->
Office Status: 102
Microsoft Office Home and Student 2007 - 100 Genuine
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 77F760FE-153-80070002_7E90FEE8-175-80070002_B4D0AA8B-604-645_025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_B4D0AA8B-920-80070057
Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed
File Scan Data-->
File Mismatch: C:\Windows\system32\wat\watadminsvc.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\npwatweb.dll[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watux.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watweb.dll[Hr = 0x80070003]
Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{40BE6A72-F9D1-4FD8-B8CA-196745FEF70B}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7600.2.00010300.0.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-9YQTR</PKey><PID>00359-OEM-8992687-00007</PID><PIDType>2</PIDType><SID>S-1-5-21-2455335910-254062919-4242309600</SID><SYSTEM><Manufacturer>ASUSTeK Computer Inc. </Manufacturer><Model>U50F</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>U50F.202</Version><SMBIOSVersion major="2" minor="6"/><Date>20091127000000.000000+000</Date></BIOS><HWID>5BBA3607018400FC</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>_ASUS_</OEMID><OEMTableID>Notebook</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>102</Result><Products><Product GUID="{91120000-002F-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Home and Student 2007</Name><Ver>12</Ver><PidType>19</PidType></Product></Products><Applications><App Id="16" Version="12" Result="100"/><App Id="18" Version="12" Result="100"/><App Id="1B" Version="12" Result="100"/><App Id="A1" Version="12" Result="100"/></Applications></Office></Software></GenuineResults>
Spsys.log Content: 0x80070002
Licensing Data-->
Software licensing service version: 6.1.7600.16385
Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_SLP channel
Activation ID: d2c04e90-c3dd-4260-b0f3-f845f5d27d64
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00178-926-800007-02-1033-7600.0000-2092009
Installation ID: 094654441871866593242556852594041126894104661523921766
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: 9YQTR
License Status: Licensed
Remaining Windows rearm count: 2
Trusted time: 10/20/2012 7:02:20 PM
Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: N/A
HealthStatus: 0x0000000000000000
Event Time Stamp: N/A
ActiveX: Not Registered - 0x80040154
Admin Service: Not Registered - 0x80040154
HealthStatus Bitmask Output:

HWID Data-->
OEM Activation 1.0 Data-->
OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
APIC _ASUS_ Notebook
FACP _ASUS_ Notebook
DBGP _ASUS_ Notebook
HPET _ASUS_ Notebook
MCFG _ASUS_ Notebook
ECDT _ASUS_ Notebook
SLIC _ASUS_ Notebook
SSDT PmRef CpuPm

My System SpecsSystem Spec
20 Oct 2012   #12

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please try installing the WAT update again. If you get the same error, please open an Eleveated Command Prompt, and run the following commands

DIR C:\Windows\Servicing\*.* /AR /S
ICACLS C:\Windows\Servicing\Packages

Post the results.

Here are some instructions to make life easier
1) To open an Elevated Command Prompt Window (the CP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.
My System SpecsSystem Spec
20 Oct 2012   #13

Windows 7 Home Premium x64

Got the same error so I ran the command:

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.
C:\Windows\system32>DIR C:\Windows\Servicing\*.* /AR /S
Volume in drive C is OS
Volume Serial Number is 56EE-C53A
File Not Found
C:\Windows\system32>ICACLS C:\Windows\Servicing\Packages
C:\Windows\Servicing\Packages NT SERVICE\TrustedInstallerI)(F)
NT SERVICE\TrustedInstallerI)(OI)(CI)(IO)(F)
Successfully processed 1 files; Failed processing 0 files

I noticed after one fo the restarts that my date jumped ahead 2 days to 10/22. I restarted and adjusted the date in the BIOS but I'm wondering if an issue with the date/time could be causing problems.
My System SpecsSystem Spec

20 Oct 2012   #14

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

OK - having made a fool of myself....

There's nothing wrong in that output.
The date change is a little odd - a word of advice, though - use Windows, rather than the BIOS to change teh system date, this ensures that settigns are properly adjusted,
I'm not sure where to go next - but I'm a little confused about some of the indication in the CBS log, it appears that tehre may be a problem with the .NET install.

first, try this

1a. Open Internet Explorer (only!) to [ignore the title & Symptoms].

1b. Dismiss/close the "automated troubleshooter" pop-up! - then...

1c. Ignoring any "Not recommended" or similar warnings, run Fix It 50202 in DEFAULT and then AGGRESSIVE modes. [1]

2. Logoff & Reboot & then run a manual check for updates at Windows Update, etc., etc...

the try installing the WAT update and running the CheckSUR too again.
My System SpecsSystem Spec
20 Oct 2012   #15

Windows 7 Home Premium x64

OMG I llove you I love you I love you. Windows is currently downloading and installing updates. Once done I'll install the WAT update and Check SUR as well if that's still necessary. Once I'm sure everything work I will check this off as solved and be forever in your debt.
My System SpecsSystem Spec
20 Oct 2012   #16

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

A little way around the houses, but we got there in the end!
My System SpecsSystem Spec
20 Oct 2012   #17

Windows 7 Home Premium x64

WAT update and everything ran fine. Thank you again for your help!
My System SpecsSystem Spec
21 Oct 2012   #18

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Great! - good luck!
My System SpecsSystem Spec
04 May 2015   #19

Windows 7 home premium 64bit

Message for NoelDP if you're still around this forum
I have just replaced an aging HDD and reset my system to factory build (Dell System Restore) on a new HDD.
- I've done this a few times and never had any issues.
This time, I got exactly the same problem as Panchan83 - I followed different fixes and instructions until I found this thread, but then I went step by step and got stuck at message #14 from October 2012.
- every time he said something didn't work, I got the exact same error messages (every time)
--- the address Windows Update error "0x80070002" or "0x80070003" is not accessible to me through Internet Explorer (not a connection issue, I can access plenty of other pages)
--- I can see that page from Chrome and ran the "MrFixIt" (I already had) and it didn't change anything

What do you need to see from me to help?
My System SpecsSystem Spec
04 May 2015   #20

Windows 7 home premium 64bit

Not wanting to wait, I kept looking and found this article which has fixed the issue, for me
My System SpecsSystem Spec

 Windows 7 cannot check for updates & error 0x80070002

Thread Tools

Similar help and support threads
Thread Forum
Windows Update cannot check for updates - 8007370B error
I've had this error on a few occasions and have managed to work round it by doing a rollback or using an Acronis backup but this time no luck. I have tried 3 times from different backups and each time I end up with the same error where Window Updates no longer works, all unfinished updates...
Windows Updates & Activation
Win7 sp1 x64 - Error 0x80070002 when find new updates
Hello! I have a problem with searching new updates - i've get error code 0x80070002 every time i try it. When i try run "sfc /scannow" - there is an error "Windows Resource Protection could not start the repair". In checksur.log there is no errors, but in CBS.log there is strange (at...
Windows Updates & Activation
Can't check for new Windows Updates - Error 80073701
Hello, I have a problem with "Windows Update": - I have the message: "Windows couldn't check for updates automatically" in "Action Center" ; - and I can't check for new updates manually. My machine is not brand new but not old either: "Windows Update" used to work properly. The OS is...
Windows Updates & Activation
Windows can not check for updates error code 800B0100
Installed Win7 yesterday and installed some drivers for it, when I went to look for updates for win7 it came up with that error code, Ive also tried doing what Microsofts website advices to do and that did not help. I also called Microsofts technicians and they weren't able to solve the problem. Im...
Windows Updates & Activation
Error 0x80070002 - Windows 7 cannot check for updates
Unfortunately, I cannot update my Win7x64. I am getting 0x80070002. I have tried to auto-repair and dozens of other things. I only now stumbled over this dedicated forum. Please see below my MGA Diagnostic. Any idea hugely appreciated. Thanks!!! Diagnostic Report (1.9.0027.0):...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App