Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: RS232 problem

11 Aug 2010   #1

Windows 7
RS232 problem

This is for the really old hands...

Got this Seiko labelprinter on Com4 (hispeed pci serial card).
My mobo is Asus P5Q3 wifi-ap deluxe.
I am always on a hell of a ride before I get this to work, these are the options shown in device mgr.:
bps 9600...115200 (several tried)
databits 8
parity none
stop bits 1
flow control none/hardware/xon-xoff (think hardware was the control of choice when it at at last worked for prior W7 installs: Beta, RC, W7)
Com 4

Msg "printer communication error".
Only possible setting on the printer is the com port.

Now I can try for days changing this and that and maybe as before it starts to work "just like that", but it is annoying: I had a crash and reinstalled W7 Ultimate.

W7 gives me a choice of two universal drivers, V8 and V10, tried to change to V8 but that doesn't change anything.


My System SpecsSystem Spec
11 Aug 2010   #2

Windows 7 Pro 64 bit

Normally you don't need to change settings on the port itself. I would look towards a driver issue here (check for drivers for the printer itself that are comparable with W7)
My System SpecsSystem Spec
11 Aug 2010   #3

Windows 7

Nothing here is compatible with W7, it was made in the early Windows 95 days!
Below is from the readme.
Haven't got a clue how to disable fifo, as there's no option for it in the device mgr, on itself or under the Com4.

Windows 3.x users should add a COMxFIFO=0 statement in the 386 enhanced section of your SYSTEM.INI file (substitute the x with the appropriate COM port--e.g. COM2FIFO=0). For more on this option, read the SYSINI.WRI file in your Windows directory.

Windows 95 users can disable COMFIFO by following these steps:
1. From the Start Menu, Select Settings-->Control Panel
2. Double Click on the System Icon
3. From the System Dialog Select the Device Manager Tab.
4. Click the "+" by "Ports (COM & LPT) in the device list.
5. Select the COM Port to which the SLP is connected and click the Properties button.
6. In the Communication Port Properties Dialog select the Port Settings tab.
7. Click the Advanced button.
8. In the Advanced Port Settings dialog, clear the "Use FIFO buffers" checkbox.
Windows NT 4.0 users can disable COMFIFO by following these steps:
1. From the Start Menu, Select Settings-->Control Panel
2. Double Click on the "Ports" Icon
3. Select the COM Port to which the SLP is connected and click the "Settings..." button.
4. Click the Advanced button.
5. In the Advanced Port Settings dialog, clear the "FIFO Enabled" checkbox.
My System SpecsSystem Spec

11 Aug 2010   #4

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64

Right click on Computer
Select Properties
Select Device manager
Expand Ports and right click on the Com port you are trying to use.
Select Properties
Select the Port Settings Tab
Select advanced
Uncheck Use FIFO buffers.
My System SpecsSystem Spec
12 Aug 2010   #5

Windows 7


Had a look for the 100th time and I actually managed to overlook one option: auto flow control...
Now it's working !

Attached Images
RS232 problem-screenshot.jpg 
My System SpecsSystem Spec

 RS232 problem

Thread Tools

Similar help and support threads
Thread Forum
Intel Rapid Storage Technology problem : Empty port problem
Windows 7 Home Premium, 64 bit Gateway Laptop NV55C (I would upgrade ut currently not working so a major hardware upgrade is gonna have to wait :( I've got the latest SATA AHCI Driver for my system according to Gateway. As for the latest Intel RST software/drivers, I have version on...
Hardware & Devices
Blurry Text problem, EDID and registry editing problem on an AMD card.
EDIT:I have found a solution, using a DVI to HDMI cable on an amd card will fix this problem, this thread can now die, hopefully someone else will find it if they have this problem. Basically, i know what the problem is, but not how to rectify it. My tv (Sceptre X235BV-FHD, a rebranded sony...
Graphic Cards
Usb to serial rs232 no working drivers
Hello, so I bought cheap usb to rs232 cable off ebay and been trying to get it working. I tried installing many different drivers from internet and still windows is not recognizing my cable. I tried to copy drive file to system32\drivers, no luck. Has anyone else had similar problem? Do I need...
HL USB RS232 driver
Hi guys I purchased a HL USB RS232 (serial to USB adapter) and the drivers that came with it are not being detected by windows 7. Would anyone happen to have a link where i could find a working driver for Windows 7. Thanks
code 10 error,usb to rs232 cable
i am using core 15 processor,dell n4110 laptop,, i tried to connect profolic usb to serial(rs232) cable. i tried in win7 professional and professional i installed but device is not working.. error statement is coming as "this device not srarted(code 10 err0r:cry:)"
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:44.
Twitter Facebook