Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: unallocated - not initialized

26 Feb 2013   #1
dido mamoun

windows 7 home basic 64bit
unallocated - not initialized

Hay guys,
I have a WD external with a password property. When i plug it in my laptop it works fine but after i type the password the laptop freezes for a moment then the external gets disconnected and the process starts all over again and sometimes the autoplay message shows up (after i unlock the external) and when i try to open it the laptop also freezes and a message shows up saying: "parameters are incorrect". When i opened disk management (after reading posts from many websites) i found that the external is UNALLOCATED and NOT INITIALIZED.
Can any one pleeeeeeeease help me?

My System SpecsSystem Spec
26 Feb 2013   #2

W7 Home Premium 32bit

Not enough info.

Have you been using the external successfully before? As well as successful password entry?
Did you just receive it and now want to try to use it?
Do you want to maintain the password security?
Do you have data on it that would kill you to lose?
Have you been disconnecting it while its been mounted in the operating system? (That is not good)

If just received, & no data worries, why not try to initialize it in Disk Mgmt and give it a letter?
My System SpecsSystem Spec
26 Feb 2013   #3
dido mamoun

windows 7 home basic 64bit

Yes, i have been using it successfully before and had no problem with the password entry. Ofcourse i want to maintain the password sercurity and i have very important data on it. Nope, i had never disconnect it while being mounted in the operating system.
Plus when i open disk mgt and right click on it i dont find the new letter or the initialization as one of the available options!
My System SpecsSystem Spec

27 Feb 2013   #4

W7 Home Premium 32bit

Go to a friend with a computer and try the external there to see if it's recognized and the data can be accessed.

Also give us the specs on the WD.
My System SpecsSystem Spec
27 Feb 2013   #5
Microsoft MVP

Windows 7 Ultimate X64 SP1

If it will work try to test the external, it sounds like it may be bad. Use the WD Digital Data Lifeguard.
Hard drive(s):
Pick one for your HDD brand or use Seatools.
7 Free Hard Drive Testing Software Tools
My System SpecsSystem Spec
27 Feb 2013   #6

Windows 7 Home Premium 32 bit

Hi dido mamoun,

Are you using WD Smartware to password protect your external drive?

Have you tried to remove the password protection with WD Smartware and checked whether it helps to access the drive?

Setting up security to lock or unlock a WD external drive with WD SmartWare

Smartware, as I understand, has always been a problem and pest many people loathe.

In any case, it does not hurt to run Data Lifeguard Diagnostic for DOS and check the health of your drive as a first step as Britton30 wisely counselled.

Download from

Create a bootable MS-DOS pendrive with Rufus Rufus - Create bootable USB drives the easy way , unzip the download into the bootable pendrive, boot from it and then against the command prompt type dlgdiag5.exe and press enter to run it. ( Do only the Quick and Extended Tests. Do not write zeroes which will destroy all data.)
My System SpecsSystem Spec

 unallocated - not initialized

Thread Tools

Similar help and support threads
Thread Forum
WD My Book Not initialized / Unallocated
Greetings, I will cut right down to the issue at hand seeing that I've spent two hours on this so far and no luck. The drive worked perfectly yesterday. It might of been connected through the USB port when I had an error screen (blue screen) about my SD port and then the system restarted itself. I...
Hardware & Devices
How do i fix unknown, not initialized and unallocated external hd?
Please help me fix this problem. any information you need just ask me i will tell you all you need. Thanks in advance
General Discussion
How do i fix unknown, not initialized and unallocated external hd?
Please help me to get my important data from my bad hard disk, I have a segate 500 GB usb external HDD, It was working fine since last 3 years. yesterday i connect this to a XP machine, and start coping some data. the coping speed was very slow, so I restarted the machine in between. After that...
Hardware & Devices
USB Drive Not Initialized and Unallocated
Hello, I have an external USB drive with a lot of data on it. Unfortunately, I'm no longer able to access the drive because it shows up as "Not Initialized" and "Unallocated" from Disk Management. I'm attaching a copy of exactly what I see: ...
Hardware & Devices
Disk showing as unallocated/not initialized
Hi, I am using Windows 7 Ultimate 64bit. I bought a second internal hard drive about a month ago. I partitioned it and used one partition for Windows backup and the other partition is for storing data. I moved a lot of data from my primary disk on to the partition on the new disk. ...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:33.
Twitter Facebook