Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Belkin Network USB hub F5L009

12 Dec 2010   #41

Windows 7 Home Premium 64 bit

Quote   Quote: Originally Posted by sranta View Post
sranta. Thank you very much. That is so easy, fixes the problem. What's more, the user interface is easier to use than the Belkin original. Install, run, see the printer listed, check the options, Windows installs the printer driver, job done.

My System SpecsSystem Spec
03 Jan 2011   #42

Vista Home Prem 32bit

A thought occurs to me - is this issue perhaps something to do with the usb drive formatting? My usb drives are formatted NTFS. Has anyone tried reformattting as FAT32?
My System SpecsSystem Spec
04 Jan 2011   #43

Windows 7

I used to have the problem too of constant disconnection. I fixed it about 2-3 months ago with any recurrent problems. I just reinstalled with latest software (connect.exe) and made sure I run it always as Windows VISTA compatibility (i am using VISTA professional as my OS). I took reinstalling a few times but the last time was the charm. No altering of ports was required. Make sure Belkin USB control center is running with same settings as mentioned above (in VISA compatibility mode). see attached pic

Attached Images
Belkin Network USB hub F5L009-belkin.jpg 
My System SpecsSystem Spec

16 Jan 2011   #44

Windows 7 Home Premium 64 bit

Quote   Quote: Originally Posted by andygc View Post
Quote   Quote: Originally Posted by sranta View Post
sranta. Thank you very much. That is so easy, fixes the problem. What's more, the user interface is easier to use than the Belkin original. Install, run, see the printer listed, check the options, Windows installs the printer driver, job done.

Worked OK for small documents, but as soon as I started trying to print photographs it all went wrong. Printer disconnects part way through the job, then reconnects three or four times during a 6x4 high quality print, each time printing the first part of the file again. Tried increasing the disconnect timeout to 300 seconds, tried using Belkin's connect.exe with the SX Virtual Link driver, even tried the Epson Stylus Photo R220 driver (there's no R200 available from Epson, just the driver shipped with Windows 7) - that worked briefly.

Looks like I'll just have to give up. Belkin are still listing this hub on their UK web site even though it doesn't have Win 7 support and there is no mention of operating system support in the product details - there may be a lot of unhappy people out there.
My System SpecsSystem Spec
28 Jan 2011   #45

Windows 7 Home Premium 64 bit


Several chats by webmail with Belkin support. The numbers are their successive suggestions - I was transferred to a "Technical Support Escalation Agent" after the first couple of contacts.

1. Try deleting everything Belkin and reinstall the F5L009 software - yes, I knew it wasn't going to work, but heigh-ho.

2. Try the F5L049 software. Had to go into tools to find the F5L009 and connect to it, but got there in the end. No go, still kept disconnecting.

3. Try connecting another device - a scanner or a drive. Tried a drive - tried copying a bundle of directories - kept disconnecting.

4. Try the software for the F7D4301 Play Max router - which also has Silex USB ports. Despite having to cancel the setup program once the install was complete, able to access the USB Print and Storage Center from the Router Monitor pop-up menu. Found the hub, found the printer, installed itself as a shared printer.

Bingo! Printed a 130MB hi-res colour file with no disconnects. Transferred 7GB of files to the USB drive at the same time.

Still the problem of the router setup program appearing at each boot and having to cancel it, but at least my shared network printer is shared again.
My System SpecsSystem Spec
28 Jan 2011   #46

Windows 7 Ultimate x64

October 2010.

From me to the Belkin Technical Support:

Few days ago I was writing to you to get help for my F5L009 because it was not working under Windows 7, and (name) from Belkin Technical Support answered my request very correctly saying that "At this time, there has not been any mention of releasing Windows 7 drivers".

Well, investigating a bit, I believe I found a possible solution to Windows 7 problems: all you need change (or add) to the Belkin Control Center installator program is an actualized copy of SXUPTP.SYS.

The sxuptp.sys driver from Silex Technology Inc, version allows the comunication between Windows 7, the Belkin Control Center App, and the devices attached to the Belkin F5L009 device in a stable and secure way.

Of course, perhaps this is not practical for the US patents but perhaps you can develope your own solution investigating this tip.

Sorry the inconvenience, I hope to be useful to you; I bought the device in London but in the country where I live there is not an official service, customer attention or resellers from Belkin, itīs a pitty.

Please, donīt hesitate in feedback me. Thank you for reading this, I apologize you for my English and have a good day!



By the way, I never got a response from the Belkin Technical Support, then, I try to share a possible solution in this forum.

Step by step:

a) Install drivers from Belkin and close the program.

b) Download and install drivers from Silexamerica. If you need restart the system, be sure the program is closed too before continue.

c) Search in the C:\Windows folder the SXUPTP.SYS file from Silexamerica. You will found them twice or more. Please, select the new version of SXUPTP.SYS file (version or newest) and copy it.

d) Paste it in C:\Windows\System32\drivers\ When the system asks for permission for a replacement, select YES. Make sure the file you're pasting is the newest, itīs more big than oldest (289 kb vs 77,1 kb) and, if you revise the new file with the right button / properties / details, you can see the newest version

e) Now, you can (or not) unninstall the Silexamerica software and use the original Belkin interface without problems with all your devices. Be careful, uncheck at Windows start the Silexamerica software if you use the Belkin software again.

Have a nice day!
My System SpecsSystem Spec
29 Jan 2011   #47

Windows 7 Home Premium 64 bit

Quote   Quote: Originally Posted by piscolabis View Post
you can see the newest version
I did install that driver in an earlier attempt - see previous postings - and I tried to access the hub using the Belkin Control Center, and, following reboot, the Silex Control Center. It's easy to check which driver the Control Center is using by looking in Help - About.

This does not provide a stable interface to the hub - as I posted previously, I have random disconnects part way through large print jobs.

The driver installed by the Max Play software is and, with the Max Play version of the Control Center works perfectly on my 64 bit Windows 7 system
My System SpecsSystem Spec
05 Feb 2011   #48

windows xp home
getting this to work

I am running win XP Home and have this hub which as most of you know is a bitch to get to work .
I have run the original software for F5L009 , also run the latest Silex software and tried the F5L049 and also the Max play setup .
All have the same outcome on first installation it works and when I turn off the PC and start again everything ok until the hub control panel comes up and it all freezes .
On checking the driver under device manager it states that this is an unsigned driver and it will not initialise it .
If this forum cannot help , after belkin do not seem to be able to this product will end up in the trash.

Thanks Derek.
My System SpecsSystem Spec
06 Feb 2011   #49

Windows 7 Home Premium 64 bit

That's very odd. The hub normally works on XP without any problem at all. Have you contacted Belkin support? I found them to be helpful - I contacted them through their website (I had to register first) and when the first couple of responses didn't solve the problem my question was escalated to somebody more senior.
My System SpecsSystem Spec
06 Feb 2011   #50

windows xp home

I have tried Belkin and have done what they requested , delete the software reinstall with security off and still it refuses to allow my windows explorer to work on reboot once the hub control center is on the screen .
My System SpecsSystem Spec

 Belkin Network USB hub F5L009

Thread Tools

Similar help and support threads
Thread Forum
Cannot Setup Wireless Network (Belkin N1 Network Card)
I'm trying (desperately) to set up my network on Windows 7, but have hit a bump in that it just cannot find my network. I checked Device Manager to see if the card was found - it was with a troubleshoot exclamation point on it. I removed the card, used the installation disc and am not able...
Network & Sharing
How do I get a Windows 7 Driver for Belkin F5L009 USB hub
I have a Belkin F5L009 USB Hub and it is installed and working fine on my laptop running Windows Vista. I want to install it on my wife's new laptop running Windows 7 Home Premium OS. When I install it off the disc it finds the hub's IP address but when I try to install it say it has detected an...
Issues with Belkin USB network hub
Hi. I have a Belkin USB Network hub. Works like a dream on Windows XP. Now I have it on Windows 7 Ultimate 64Bit. Works ok when installed. After reboot it doesn't work anylonger.
Network & Sharing
Issuse with Belkin USB Network HUB.
Hi. I run Windows 7 Ultimate 32bit here. I have a Belkin USB Network HUB f5l009. It has worked before on W7U, but not now. I can see it's IP address in my router, but cannot see the IP address in the HUB itself.
Network & Sharing
Belkin Network
While the Belkin router (F5D8232-4 }seemed to be fine, the Belkin adapter (F5D8055) only arrived yesterday. Since then, I have been trying to get the network operational between my rigs, of which the first is running W7, and the second is running XP MCE (since the W7 drive died). Both OSs are set...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 16:04.
Twitter Facebook Google+