Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: AC'97 front panel, mic not working

16 Jan 2017   #1
danielocdh

Windows 7 Ultimate x64
 
 
AC'97 front panel, mic not working

I lost my old panel which worked ok, I'm using a new panel but the microphone is not working.
I had interference from the usb ground to the audio ground (that's why panel is scratched/wired)
Audio output works perfectly.
The only change from when my mic worked is the panel, every configuration and drivers are the same.
Motherboard asus m5a97 r2.0, (diagram attached is from motherboard manual).
I already tried both HD and AC'97 setting on bios, with the old panel I used AC'97.

For the PCB/motherboard connections:
black = AGND
white = Line out_R
green = Line out_L
red = MIC2 (I already tried connecting it only to MICPWR and to both MIC2+MICPWR)

Any ideas what is the problem?
could it just be the jack on the panel or is there something else wrong?

Thanks




Attached Thumbnails
AC'97 front panel, mic not working-audio.jpg  
My System SpecsSystem Spec
.
16 Jan 2017   #2
fireberd

Windows 10 64 bit
 
 

Trace out the wiring, both in the AC97 plug that connects to the motherboard and the jack. An Ohmmeter can be used to verify the wiring from the AC97 plug to the Pink mic jack Tip, Ring and Sleeve.
My System SpecsSystem Spec
16 Jan 2017   #3
danielocdh

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by fireberd View Post
Trace out the wiring, both in the AC97 plug that connects to the motherboard and the jack. An Ohmmeter can be used to verify the wiring from the AC97 plug to the Pink mic jack Tip, Ring and Sleeve.
I don't have one but I'll try that as soon as I get my hands on one, thanks.
Any idea what should be the correct wiring for the red cable? (MIC2/MICPWR/MIC2+MICPWR)
My System SpecsSystem Spec
.

17 Jan 2017   #4
fireberd

Windows 10 64 bit
 
 

I have no idea on the wiring as the colors used can vary from vendor to vendor.
Pin 1 in the connectors, according to your drawing, would be the signal (tip) line. Pin 2 is the +5VDC (ring) line and the ground is noted.
My System SpecsSystem Spec
19 Jan 2017   #5
danielocdh

Windows 7 Ultimate x64
 
 

I couldn't get an ohmmeter but I tested with my phone line (don't try this at home... lol).
Mic red cable was faulty on 2 places(middle and near the connector), I just changed it with a piece from an old UTP cable.

For my setup right now I have connected both MIC2+MICPWR on red.

Thanks fireberd for the idea.
My System SpecsSystem Spec
Reply

 AC'97 front panel, mic not working




Thread Tools




Similar help and support threads
Thread Forum
Front Usb Panel Not Working.
Sir, Motherboard - Asus P5g41t-MLX Last week i changed my cpu cabinet. Done the installation. But, after installation, i have some problem with the cabinet's front usb ports & audio ports. The motherboard have 4 usb ports & 3 audio ports (rose,green.blue) at the back side. All these are working...
Hardware & Devices
Front Panel on both builds not working
The Bios has already set up HD on Audio I put in the Front Panel on the right slot Also the Cd with the drivers are installed Help please? Thanks! Only the Front Panel Audio Is not working Motherboard is Z87-A Antec Case http://www.memoryexpress.com/Products/MX37559
Sound & Audio
front panel headphones not working
I have a Gigabyte GA-P55M-UD2 mobo and realtek HD Audio installed on my computer which is a Win 7 64-bit Home premium prior to all this i had a major computer update i think it was close to 70MB or so, downloaded and installed it restarted computer, everything was working fine 2 days ago...
Sound & Audio
mic not working on front panel
Hi I bought my wife a new pc as the old one was a single processor and very slow. It has 2 issues. The new one seemed straight forward, quad core much faster but two issues are annoying enough to make my wife not want it. 1. The front panel seems to be wired differently to the old pc - my...
Sound & Audio
Mic not working in front or rear panel.
Hey, my headset was working fine in Windows XP but ever since I upgraded to Windows 7 it hasn't worked, I've tried pretty much every setting in the Realtek command center, updating drivers and so on but nothing seems to work, all I can record is static noise :mad: Any chance someone can help me...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App