Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ATI Catalyst Control Center wont open

11 Jul 2010   #51


Yeah, the specs don't match - but there's definitely an ATI GPU there. (Just have to wait for the h/ware lds screenie to confirm)

My System SpecsSystem Spec
11 Jul 2010   #52

winodows 7 home premium

Quote   Quote: Originally Posted by smarteyeball View Post
Quote   Quote: Originally Posted by sygnus21 View Post
Since this is a Mobility Radeon HD 4300 series card you'll need to visit Samsung for the video card software/drivers.
I thought so too at one stage - but the mobility chipset is supported as per the vendor ID list.

And it has to be a integrated HD 4300 and not an Intel - otherwise the ATI drivers, or CCC for for that matter, would simply not install.

It would give a 'no supported hardware found' warning and halt the installation at the 'detecting hardware' stage.

Quote   Quote: Originally Posted by Jmusgrave View Post
CW100947.INF is cw100954.inf in my file
Then where did that screenshot of yours showing CW100947.INF come from?

As for Windows saying the driver was 'up to date' - if you tried installing the driver after 8.74 was already installed, then that's why Windows is claiming the driver is up to date.

As the situation stands:

The GPU will install the most current 10.6 display driver. The screenshot has proved this.

CCC is still playing silly buggers.

(normally, when CCC has played silly buggers for me - a quick trip to 'driver sweep/clean then reinstall town' has fixed it )

For the heck of it, with the 8.74 driver already installed, try re-running the CAT 10.6 installation. I'm not sure which CCC version you currently have installed at the moment. 10.3 or 10.6

Quote   Quote: Originally Posted by Jmusgrave View Post
when I upgraded to windows 7
I just noticed this - when you say upgraded, was it:

A clean instal from XP to Seven
A clean install from Vista to Seven
Or an inplace upgrade from Vista to Seven?

Also, just to double check the chipset, could you post a screenshot the GPUS Hardware lds

(Device Manager > Display Adapters > Properties > Details > (drop down arrow to Hardware lds)

Attachment 84520

This recalcitrant CCC could still be caused by a conflict by another app, or the wrong version of the Microsoft Visual C++ Redistributable version that CCC needs to run is not installed.

So, could you please also post a screenshot of the installed C++ Redistributable versions installed?

CCC uses version 9.0.37229.4148

Attachment 84522
sorry for the delay smartyeyeball, there were so many replies I missed this one, im really clueless when it comes to this, never dealt with a laptop before let alone a graphics cards, when I bought the laptop ati was installed, it was a floor model from futureshop, when I booted up the computer ati ccc was there, i recieved a windows 7 upgrade disc, i did an upgrade instead of a full install, then went to the samsung website to upgrade software to win 7 compatibility, including ATI CCC, about a week ago, i got an error message saying the gpu was no longer supported, and so I attempted to uninstall the drivers and software and reinstall, and here is where I am i have inserted a screenshot of the gpus hardware

ATI Catalyst Control Center wont open-capture.png lds

not sure how to do a screen shot of microsoft c++ versions but I have 2005, and 2008 installed

and the screen shot of cw100947.inf im looking for that, but again im new to this aspect, hope this helps and thanks again


My System SpecsSystem Spec
11 Jul 2010   #53

winodows 7 home premium

hey smartyball here is 2 screenshots of what i see after 10.6 ccc install[ATTACH]ATI Catalyst Control Center wont open-capture.png1.png[/ATTACH] hope this helps as well


Attached Images
ATI Catalyst Control Center wont open-capture.png 
My System SpecsSystem Spec

11 Jul 2010   #54


I just a quick look through the .inf and the hardware PCI\VENxxx of your GPU isn't there.

However the report.xml matches mine re the redist, CAT version and driver installed.

But the 'errors occurred during install' after the installation is interesting. Unfortunately not knowing what errors they were make it difficult. I can't find where the installation output log is located either (ATI make entries every bloody where).

TBH, I'm running out of ideas - Catalyst installs, but the driver doesn't. Yet the driver can be installed - but CCC won't open...

I'm not sure if it's because the chipset is actually unsupported, or whether CCC failing to open is due to a conflict that stems from something that went awry because of the upgrade to Seven.

I'm not sure if adding that GPU's hardware id to the .INF prior to installing Catalyst will help or not (never tested it myself).

I'll have to sleep on this one Jamie - as I'm now just eduguessing

Sorry mate. I'll have to get back to this later.
My System SpecsSystem Spec
11 Jul 2010   #55

winodows 7 home premium

not a prob buddy, I really do appreciate your help, to note though, ATI did install fine after the windows 7 upgrade, the upgrade was done months ago, this just happened, thats whats not making sense, the best of it is, samsung had the software for ati available when i upgraded to windows 7, but now its not on the website, i keep trying to reach tech support to no avail, maybe ill have more info in the next few days, im giving up for now

My System SpecsSystem Spec
11 Jul 2010   #56

Windows 10 Pro

Do call tech support, and please keep us informed.

Good luck
My System SpecsSystem Spec
20 Jul 2010   #57

Windows 7
Driver Possiby

A couple of days ago i was having the same problem with a dell laptop, Not mine of course, but it seems when he did the upgrade from vista to 7 it didn't recognise that his card was a radeon 4570..... Instead lovely windows decided to put it down under 4500 series and put a windows driver incharge of this..... Make sure your driver dosn't have (WDDM 10......) on the end of the driver or hardware when you go into device manager.
My System SpecsSystem Spec
01 Aug 2010   #58

Windows 7 Ultimate x64

ok, I just saw this post and might just possibly/hopefully have come across something new for you to try.

This is a strange one...I did not even know this (Global Assembly Cash/key token) even existed...but it is worth a try.

Go here: [SOLVED] catalyst control center wont start??????????? - Rage3D Discussion Area

and look at the very last post (by Cythar dated July 29 2010)

who knows, it just might work.

good luck.
My System SpecsSystem Spec
01 Aug 2010   #59

Windows 7 Ultimate x64

To save you some effort here is what the above mentioned post says:

This is an old thread, but it's one of the top search results for "ccc won't run" so I wanted to post another possible solution here. My solution was to clear out the Windows GAC (Global Assembly Cache). In Windows 7, you can browse directly to "C:\Windows\assembly". Sort by "Public Key Token", then delete everything with the Token "90ba9c70f846762e" (ATI's key). You'll obviously need Administrator privileges. No reboot needed either. Reinstalled CCC and it ran perfectly!

The GAC lets you share DLL's that are the same version number. If it's in the GAC, any installer will NOT install a new DLL - it'll use the one in the GAC. If the GAC DLL is corrupted, you're majorly SOL.

When I reinstalled the CCC, it took longer to install then it had before. Presumably, this was due to the installer copying all the correct DLL's to my hard drive. And no ATI DLL's have made it back into my GAC.

To give credit to the original poster, here's the page I found this fix on:
My System SpecsSystem Spec
12 Aug 2010   #60

windows 7 32bit


I had the same problem like you do, i tried everything nothing worked.
At first times catalyst driver worked but after a few months when i reinstalled my win7 i had a fight like you.

So you have a laptop, so here it goes.

Download this attachment file, start the download, after its done, click install.

You can user the Express option it will work, it solved mine, hope it solves yours too.

My System SpecsSystem Spec

 ATI Catalyst Control Center wont open

Thread Tools

Similar help and support threads
Thread Forum
Catalyst Control Center wont oepn
this is the error i get
Graphic Cards
No matter what i try Catalyst Control Center Wont Install
Hey guys, Recently ive been trying to use my graphic card for a certain program but it was not detecting it. No biggie. Then i realized i couldn't even open my Catalyst Control Center. So i uninstalled it completely using Driver Sweeper, manually deleting file, and Clearing my registry,...
Graphic Cards
Catalyst Control Center missing/Wont install
Hello, I've seen some useful information on this site so I really hope someone can help. I recently upgraded to a HD6870. Installation went OK, have a much better experience with the new card. Then I learnt about Eyefinity and thought I'd give it a go having some spare monitors around. ...
Graphic Cards
Cant Open CCC (Catalyst Control Center)
Sorry, if this is in the wrong section. I'm very new to these forums. :) Okay, my problem is this... I cannot open the Catalyst Control Center! I was able to open it a little while ago! I system restored and I uninstalled and reinstalled CCC! Still nothing happens. When i right click on my...
Graphic Cards
ATI Catalyst Control Center Wont Appear...
Hi people. I've just installed windows 7 RTM, 32-bit on my Asus, with an ATI Radeon HD 3470 graphics card. The driver for it is installed and working I think, but I can't seem to get the Catalyst Control Center to work.. I've installed the ATI Catalyst™ 9.7 Suite for Windows 7 (32-bit)...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:01.
Twitter Facebook Google+