Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't join Homegroup

19 Jan 2009   #1

Windows 7
Can't join Homegroup

I've seen that others are having problems similar to mine. This brings a certain peace to my life.

Problem: I'm unable to join my computers to a homegroup. The problem exists in both directions. If either one has a homegroup, the other cannot see it. When I go to network and sharing center, I can see the option: "HomeGroup: Ready to Create" but I do not see an option to join. If a homegroup exists on the computer, I see "joined".

Current Configuration:
PC (home grown AMD Athlon)
Laptop (Dell Latitude E5500).

administrator account on both computers, same password
user account on both computers, same password

Network Configuration: Verizon FIOS Router/WAP combo. Laptop is using cable to connect. Wireless is currently turned off on laptop.
Both computers are in the same "workgroup". Both computers are set to "Home network".

1. Unable to see homegroup on network in order to join it.

2: in network status, in the map at the top of the screen, on the PC it is called "Network" and on the laptop it is the same name as my SSID.

3: from time to time, as I'm troubleshooting, I observe that the link between my network icon and the internet icon, within the status map, shows a red X, and "connections" will only show "local", and yet I'm still able to surf the internet.

Troubleshooting steps taken:
1. chose "leave the homegroup" on the PC and create it on Laptop. fail.
2. performed the old and faithful "share" and was able to share an entire disk (e:) from the PC and see it, and manipulate it from the laptop. (ping also works, but that's obvious now). Shared a folder on the Laptop and was able to access it from PC. PCs show up in "computer / network" on both computers, and shares are visible there also.
3. On another forum post came a suggestion to disable IPv6.
- Went to properties for the LAN connection on both computers and unchecked "Internet Protocol Version 6 (TCP/IPv6).
- restarted both PCs. (unnecessary, I know now)
- tried to create homegroup and received error: "a homegroup can only be created on a home network". Repeated this, and the result on both machines.
- checked IPv6 box back on in connection settings.
- repeated steps again and created homegroups with same being that I cannot join the newly created from from other other computer.

I've tried to provide a comprehensive set of the experience.

Your help is appreciated!
My System SpecsSystem Spec
24 Jan 2009   #2

Windows 7 64 Bit

Hey i think im having a similar problem to you. I originally had homegroup working fine on our network. But then one computer lost the homegroup and was unable to reconnect.

I tried to leave the original homegroup but now i just have the option to join it and when i try it says a homegroup cannot be created on this computer. 0x80632094 - error code.

Any advice would be greatly appreciated. (like how do you get rid of an old homegroup no-one is joined to or can join).
My System SpecsSystem Spec
25 Jan 2009   #3

XP/win7 x86 build 7127

create a new homegroup: control panel>network and internet>Homegroup

Here either create a new... or easy fix is to just change the password, manually input or have windows create new pass for you... then go to the other machines with the homegroup, do same thing, change password to same as pc#1.... easy pie
My System SpecsSystem Spec

25 Jan 2009   #4

Windows 7 64 Bit

Hmm that seems to take me back to the join a homegroup page. Where whether i type in the original homegroup password or anything else it says Windows cannot set up a homegroup on this computer. with the error code as in my post above.
My System SpecsSystem Spec
25 Jan 2009   #5

Windows 7 RC 7100 32bit/64bit

I've been having this problem myself.

It appeared that I was using a couple of virtual network adapters created by VMWARE or Virtual PC.
Those adapters were autoconfigured as Public Network, which dissalowed my computer to join the homegroup.


1. Disable all other network adapters on both computers.
2. Connect both computers with cable and try again, if possible.
3. Connect both computers with wifi and try again, if possible.
4. Go to Network and Sharing Center on both computers and see if there's another adapter, set to Public Network. Change that to home network too.

See if it helps
My System SpecsSystem Spec
25 Jan 2009   #6

XP/win7 x86 build 7127

what about "change the password" to the homegroup, are you able to click on and do that?

help me understand a lil more here....

1. Did you "join" or make a homegroup when first installed? write down the password?
2. Does windows report you as on a "homegroup", either pc?
3. Have you turned ON Network Discovery? ie: advanced sharing settings, under (current profile)
My System SpecsSystem Spec
25 Jan 2009   #7

XP/win7 x86 build 7127

also, are the pc's setup on dhcp or static? if static, do you have the router's ip for the dns server?
My System SpecsSystem Spec
25 Jan 2009   #8

Windows 7 64 Bit

Originally both computers were on a homegroup as set up with the windows install (both connected via ethernet and 802.11g). Then both computers had edimax 802.11n cards installed and drivers updated.

After that one of them then could not join the homegroup while the other was still joined to the original homegroup.

I then left the homegroup on the second computer in order to set up a new one.

Now on the first computer (connected by ethernet and 802.11n) it shows the option to create a homegroup which results in an error message with error code 0x80630801. After some inspection this is due to the peer networking service not starting. (cant manually or automatically start it). I believe this computer has some serious hardware problems to do with a faulty motherboard. However this shouldn't affect the other computer being able to create a homegroup. (I originally had just the second computer connected to a homegroup by itself)

While on the second computer (connected just by 802.11n) it shows the option to join a homegroup which also results in an error message (code : 0x80632094). On this computer all the relevant services are started, ipv6 is enabled and all network adaptors are either disabled or set as home.

Both are set up with DHCP and have network discovery enabled and neither show as connected to a homegroup.
Change homegroup password is not an option.
My System SpecsSystem Spec
25 Jan 2009   #9

XP/win7 x86 build 7127

ok, so pc1 is connected both wired and wireless? why? there is your first problem. Secondly, how about disabling the wireless card and using the wired for pc1, see if, while still on that homegroup for the wired conn, see if you can then change password. By "not an option" do you mean it shows up and you click on it and get nothing? Or is it not there at all?

Lastly, if you just want the Ncard for pc1, disable the LAC for the wired nic, then try to CREATE a homegroup for the nic...

the key of course is the simple password you get or set yourself for the network, while going to the other pc's and just inputing the same password for all the pcs wanted on the same homegroup and voila!
My System SpecsSystem Spec
25 Jan 2009   #10

Windows 7 64 Bit

I have tried connect pc1 solely by wired and solely by wireless with no change in the errors that were produced. Its problems are definitely caused by the Peer name resolution protocol and peer networking grouping services not starting.
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Unable to join homegroup, homegroup creating computer is no more
The computer that originally created the homegroup on my network is no more. It seems that because of this that my new computer is unavailable to join the homegroup that already exists. Other computers that were part of the homegroup before the "host" computer died are still part of the homegroup...
Network & Sharing
Homegroup problems - Homegroup detected, can't join. @wit's end
I have a desktop that is connected to my Belkin router via wire. I have 3 laptops that are all connected to the router wirelessly. All computers have Windows 7 64bit and synched clocks. All are connected to a Home network. All 3 laptops detect that a Homegroup has been created on the wired...
Network & Sharing
Homegroup encountered an error / This computer cannot join a homegroup
I get a "Homegroup encountered an error" message when I try to join my laptop and desktop to a homegroup. It does not matter which one sets it up and which one tries to join. It errors in either direction. I have tried leaving and creating, no use. The desktop is wired to a Belkin 300N router and...
Network & Sharing
Cannot join Homegroup
I have two computers: Dell Inspiron Laptop connected wirelessly and a Desktop with wired connection to router. I have been trying for 4 hours to connect to the homegroup with my desktop so I can view the files on my desktop on my laptop. Now I will detail the steps I have done. 1. I tried going...
Network & Sharing
Cannot join Homegroup
I have two Windows 7 desktop Pcs, connected via a 4-port router (wired connections). I can create a Homegroup on both machines, but neither PC can detect the other's Homegroup. So when I try to join the homegroup from either PC I always get the message 'there are no other Homegroups on this...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:12.
Twitter Facebook