Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot install Cisco AnyConnect-problem with Windows Installer package

25 Mar 2017   #1
mathaggie

Windows 7 Home Premium 32bit
 
 
Cannot install Cisco AnyConnect-problem with Windows Installer package

I am trying to upgrade my VPN software to Cisco AnyConnect but I cannot get the software to install on my laptop. The installation process seems to make a fair amount of progress, but then it stops and says: "There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor."

I had a older version of Cisco VPN that worked fine for at least five years. I only ran into problems when I tried to install the newer AnyConnect. I have access to versions 3.1 and 4.1 of AnyConnect, but neither will complete the installation. I uninstalled the prior VPN software and Norton Antivirus before attempting to install AnyConnect.

I have looked through many forums to try to solve this problem, but nothing has worked so far. I have discovered that my Windows Updates are not installing (they won't even download).

Any assistance you can provide would be greatly appreciated.


My System SpecsSystem Spec
.
25 Mar 2017   #2
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi MathAggie,
can you run
sfc /scannow (note the space)

and KB947821
run the correct version 32 or 64 bit.

when completed REBOOT

then goto
C >> Windows >> logs >> CBS- from it please post the (top) cbs and SURT logs.

zip them please (not rar)


Roy
My System SpecsSystem Spec
26 Mar 2017   #3
mathaggie

Windows 7 Home Premium 32bit
 
 

Bad news on a few fronts.

1.) KB947821 gets stuck when the screen says: "Searching for updates on this computer." I let it run for 12 hours and it never made it past this part of the process.

2.) Apparently I do not have access to CBS.log on my computer. I tried to open it and/or zip it and I was denied every time.

3.) I do not see a SURT log in that same directory.

I appreciate any additional insights you might have. I apologize if this has turned into a larger undertaking!
My System SpecsSystem Spec
.

27 Mar 2017   #4
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi MathAggie,
these things are sent to try us!!.

Got a really OLD restore point or image, if so try it.

Lets try a SURT equivalent,

http://www.sysnative.com/niemiro/apps/SFCFix.exe

Roy
My System SpecsSystem Spec
27 Mar 2017   #5
mathaggie

Windows 7 Home Premium 32bit
 
 

Unfortunately, my oldest restore point only went back a few weeks. However, I was able to run the SFC Fix program. Somewhat brief, but the complete log follows:



SFCFix version 3.0.0.0 by niemiro.
Start time: 2017-03-27 10:23:10.601
Microsoft Windows 7 - x86
Not using a script file.




AutoAnalysis::
SUMMARY: No corruptions were detected.
AutoAnalysis:: directive completed successfully.




Successfully processed all directives.



Failed to generate a complete zip file. Upload aborted.


SFCFix version 3.0.0.0 by niemiro has completed.
Currently storing 0 datablocks.
Finish time: 2017-03-27 10:30:48.497
----------------------EOF-----------------------



THANKS!
My System SpecsSystem Spec
27 Mar 2017   #6
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi MathAggie,
Well the ouput tells me that CBS and SURT would have come back clean.

What it doesn't explain is why you cant access/run them!.

Did you just uninstall using programs/features
Does AnyConnect have its own uninstaller
if so did you run it in Safe Mode, it does make a difference in some cases.
What is device Manager showing

Might be a case of radical surgery i suspect remnants.

Roy
My System SpecsSystem Spec
27 Mar 2017   #7
mathaggie

Windows 7 Home Premium 32bit
 
 

I uninstalled the prior VPN using the Windows Uninstaller. I did not see a separate uninstaller for AnyConnect.

What am I looking for in the Device Manager? I poked around, but I did not see anything interesting.
My System SpecsSystem Spec
Reply

 Cannot install Cisco AnyConnect-problem with Windows Installer package




Thread Tools




Similar help and support threads
Thread Forum
IE Doesn't Work After Accessing PC Via Cisco AnyConnect
I have an end user who accesses their PC from home using Cisco AnyConnect. They remote in, work on some documents, and then disconnect. When they come in the next morning they're unable to access the Internet via IE and they're also unable to print. However, they're still able to access network...
Network & Sharing
Cisco AnyConnect diasbles internet upon exit on Windows 32bit pro
Hi, Please can someone shed some light for me, I've had to install Cisco Anyconnect VPN for all win7 laptops. All is fine in terms of users can access VPN and get on to our network. but once you quit VPN and disconnect. You cannot get internet access. I originally thought this was due to...
Network & Sharing
Cisco AnyConnect VPN Client - Installation/Use Problems
:cry: I've been suffering from Cisco AnyConnect VPN client problems for a couple of weeks. I had been a successful user connecting to my company's VPN, for years, but then tried to use the Client to connect to a different VPN server at my university, for a one time use to get access to a...
Network & Sharing
Windows Installer - can't install ANY msi package
Windows Installer crashes any time i try to install an msi. Get the message 'windows installer has stopped working'. I think the version is version 5.0 in Windows 7, but can't download this from anywher to see if reinstalling it helps. Tried to install the old 4.5 version but it won't let me. ...
General Discussion
registry access through Cisco Anyconnect client
I have an application that works without issue through a Cisco Anyconnect client on XP and Vista, but not on Windows 7. It also works on Windows 7 when accessed locally (no Cisco Anyconnect client). When I try to use it on Windows 7 through the Cisco Anyconnect client, I get an error message...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App