Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Two Explorer.exe running

21 Dec 2010   #1
EzioAuditore

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 
Two Explorer.exe running

Hi, I'm kinda confused now. Here's the story.
Yesterday, MBAM detected a infection named- Heuristics.Reserved.Word.Exploit. The file which was flagged was- C: \Windows\Installer\Explorer.exe
It always came back after reboot. Upon googling, i found that the threat name refers to the usage of microsoft reserved name outside it's default location.
So, I booted in safe mode, terminated Explorer.exe (original one), and deleted that duplicate Explorer.exe via cmd (it wont unless i terminate original explorer process).
Everything is fine now. There's one thing about which i'm concerned.
I've two Explorer.exe running sometimes, not often. Attached is the screen below.
Both are running from original default location.
Any ideas why 2 explorer.exe are running?



PS: Command line also included in the pic. Maybe if that could reveal something. And I don't have 'Launch folder windows in a separate process' checked. One more thing worth noting that the original explorer.exe and duplicate explorer.exe have same creation date and checksums.




Attached Thumbnails
Two Explorer.exe running-explorer.png  
My System SpecsSystem Spec
.
21 Dec 2010   #2
brady

 

pid 956 looks like an infection to me... are you sure the machine is clean?
My System SpecsSystem Spec
21 Dec 2010   #3
EzioAuditore

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

Whoa! That was lightning fast reply.

Ive done full scan with MBAM and KIS 2011. Machine came up clean.
My System SpecsSystem Spec
.

21 Dec 2010   #4
brady

 

How's your msconfig /startup sheet looking? The explorer.exe /* doesn't usually equal good things.
My System SpecsSystem Spec
21 Dec 2010   #5
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

My System SpecsSystem Spec
21 Dec 2010   #6
brady

 

ahh nvm... disregard... the 2nd is a 32bit explorer
My System SpecsSystem Spec
21 Dec 2010   #7
EzioAuditore

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

Msconfig looks ok. I made another snip now. And both processes seems to change their pid's everytime when they're run. See the pic. Ending explorer.exe/* doesn't closes my desktop.

@Jacee, thanks. Going to run that after this post.


Attached Images
Two Explorer.exe running-capture.jpg 
My System SpecsSystem Spec
21 Dec 2010   #8
brady

 

the 2 explorers are bit defined. 1 for 64bit and 1 for 32bit processes
My System SpecsSystem Spec
21 Dec 2010   #9
EzioAuditore

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

Quote   Quote: Originally Posted by Jacee View Post
Jacee, you want me to generate and attach the report here?
My System SpecsSystem Spec
21 Dec 2010   #10
EzioAuditore

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

Quote   Quote: Originally Posted by brady View Post
the 2 explorers are bit defined. 1 for 64bit and 1 for 32bit processes
How? It doesn't say explorer*32 in task manager? And what program would need their own separate explorer.exe?
My System SpecsSystem Spec
Reply

 Two Explorer.exe running




Thread Tools




Similar help and support threads
Thread Forum
I had 4 explorer.exe's running!
Ok, I noticed an issue is my task manager. I had 4 explorer.exe's running! It seems when opening a new folder (the way described in the link below with screenshot) is what makes it happen. Is there a FIX for this bug???? Very annoyed. ...
Performance & Maintenance
2 explorer.exe processes running
Hi guys :) i have got 2 explorer.exe processes running on my system!!! as far as i can remember it happened after i installed tune up utilities 2011 (but not sure about this) can it be some kind of virus/malware?? am using MSE and comodo firewall i have Unchecked “Launch folder windows...
General Discussion
Explorer: Running from server failed
Hi ppl, Since yesterday I can't open Computer, C:, D:, the Usermap on the desktop, Control Panel, you name it. This happened when I accidently moved the Documents folder to the My Music folder. I just wanted to delete the Documents folder in the My Music folder but from then my Windows lost it....
Software
64-bit explorer.exe crashes even when not running
Recently (in the past couple of weeks) 64-bit explorer.exe crashes even when not running (just sitting in taskbar). "Windows Explorer Not Responding" pops up. After explorer.exe is "Restarted" or "Closed", the taskbar is cleared and then restored, but with Desktop Gadget Gallery added. Clean...
BSOD Help and Support
Internet Explorer 32 Bit Running Slow
Just thought I'd share this information. I've purchased a new machine with Windows 7. Everything was fine, including Internet Explorer (8) 64 bit, until I needed to access some web functions that seemed only to be available in the 32 bit version of Explorer. Upon starting the 32 bit version...
Browsers & Mail
100+ Explorer.exe Processes Running
For starters this is my first post, so hello. I'm glad to see there's such a large Windows 7 forum. I've been enjoying everything so far. I have an OS: Windows 7 Ultimate 64-bit CPU: Intel I7 920 RAM: 12GB DDR3 1600 RAM GFX: ATI 4890
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App